1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

05 Blizzard Stuck

Discussion in 'Blizzard Plows Discussion' started by Dodgeguy4x4, Mar 13, 2006.

  1. Dodgeguy4x4

    Dodgeguy4x4 Junior Member
    Messages: 13

    I have a 2005 Blizzard 760LT plowed with it maybe 6 times and now I go to move it the other day and it will only angle right and go up and down and i tryed pushing it up again something figured it was froze up and it just wont come free any ideas??? this happen to anyone before? Also I have notice my plow is alot harder to get on because the right side pin is alot harder to get in like i have to use a hammer and the left side goes in no problem is this normal for such a new plow and never hit a curb or anything i just dont get it? any suggestions Thanks

  2. Up North

    Up North Senior Member
    Messages: 921

    I have the same plow except for 2004 model. Not sure if there is a difference between the two but I don't think so. But I would take yours into the dealer as something's not right. As for mounting, mine was a little tight for about the first half of the plowing season last year. Now it's not a problem at all, I pull up, hit the switch to draw everything together, pop both pins in from the driver side and away I go. But I would have your dealer look into that as well, it's still under warranty.

    They're good plows, they can take quite a beating for being lighter duty. Good luck and hope you get it taken care of easily.

  3. jeffw

    jeffw Senior Member
    Messages: 107

    sounds like a connection issue, check for corosion at the pins be sure your using dieelectric grease on em to protect it, un plug and plug it in a couple times. this is the num 1 problem seen with these, connector not secure or dirty.