1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

04 gmc z 71 dies while driving, won't start

Discussion in 'Chevy Trucks' started by 'Rude Dog, Aug 15, 2012.

  1. 'Rude Dog

    'Rude Dog Member
    Messages: 56

    Toook the good truck to town sunday, getting on the on ramp, got up to 40 mph, then died, initial thought was feul pump, but when checked with gauge , had 62 psi fuel pressure. pulled a injector wire off, has injector pulse, sprayed starting fluid in the intake, she sputtered, till she burned up the starting fluid, tach registered rpm, so the cam sensor appears ok. Just filled her up,last week, at a different gas station than I usually go to- wondering if I got old/ bad gas ??? anybody got any ideas on what is going on ??? possible crank sensor ??? - ( Good thing I got the '89 k2500 to drive
  2. brad96z28

    brad96z28 PlowSite.com Addict
    Messages: 1,526

    Not a spark problem if it ran on starting fluid forget about a crank sensor., did u ck fuel volume?????? Pressure means nothing if you have no real flow like restricted strainer or filter, If it ran on starting fluid u have a fuel problem. Bad fuel, or low flow, ck the basics.
  3. maverjohn

    maverjohn Senior Member
    Messages: 902

    Had about the same thing on a 02 gmc, start and drive when cold die and not start when warm, put a new fuel pump in and everything is good to go.