1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

03 2500hd third brake light and brake controller issue

Discussion in 'Chevy Trucks' started by dheavychevy38, Nov 8, 2009.

  1. dheavychevy38

    dheavychevy38 Senior Member
    Messages: 283

    The truck is a 03 2500hd with a 6.0 gasser in it. The problem is that the third brake light quit working and I also lost signal power going to my brake controller telling it that the brakes are being applied. Any ideas ? I have check what i thought is all the right fuses.
     
  2. mcfly89

    mcfly89 Senior Member
    Messages: 306

    are the rest of your brake lights working?
     
  3. dheavychevy38

    dheavychevy38 Senior Member
    Messages: 283

    Yep the ones in the tail lights work and from what I can tell the bulbs are good in the third brake light. Everything on the brake controller still works in other words if you use the manual over ride it works fine just has no power when you hit the pedal.
     
  4. lilweeds

    lilweeds PlowSite.com Addict
    Messages: 1,178

    Sounds like a bad brake pedal switch.
     
  5. dheavychevy38

    dheavychevy38 Senior Member
    Messages: 283

    Is there a fuse for the third brake light ?
     
  6. Bruce'sEx

    Bruce'sEx Senior Member
    Messages: 873

    Did you use the pigtail for the brake control, that plugs in under the driverside dash? or are you hard wired?

    if your hard wired find where your brake control is getting it's brakes on signal from, it almost sounds like it's tapped into the brake lights. Doubt it's a brake switch problem if the brake lights in the rear still work.
     
  7. Bruce'sEx

    Bruce'sEx Senior Member
    Messages: 873

    likely same brake fuse for all the brake lights.
     
  8. dheavychevy38

    dheavychevy38 Senior Member
    Messages: 283

    Fuses are all good and yes it is on the pigtail that plugs in by your left foot. I figured it wasn't a switch thing only cause the other lights still work fine.
     
  9. wild bill

    wild bill PlowSite.com Addict
    Messages: 1,239

    brakes

    sound's like 1 side of your controller is burned out ,if they work off the hand control and not the pedal .that's common on some low end brake control's .:salute:
     
  10. dheavychevy38

    dheavychevy38 Senior Member
    Messages: 283

    I checked the wire comeing into the controller for power. The controller is a prodigy which my company uses in all of our trucks.
     
  11. mycirus

    mycirus Senior Member
    from Mass
    Messages: 589

    I have a 2001 GMC and have to use my manual control too for brakes on the camper. My third light works though. Here is what I found online about it. I havent tried it yet.

    "Check the VEH CHMSL fuse on the side dash fuse panel. Activation comes from the third brake lamp. If that's good, then look to the harness.

    The harness looks the same, but the plug's pin location changed on different model years. This may be where your problems lie, you may have the wrong harness.

    The light blue wire is for the controller activation feed, and the brown wire is the controller illumination line (if equipped).

    For orientation purposes, with the plug’s release tab at top, the early models had the brown at the top right corner and the light blue in the bottom left corner. Later models swapped these two pin locations."
     
  12. mcfly89

    mcfly89 Senior Member
    Messages: 306

    also that harness has a separate fuse if i remember right
     
  13. lilweeds

    lilweeds PlowSite.com Addict
    Messages: 1,178

    No that fuse is only for the 12V charging pin in the 8 way trailer plug.
     
  14. dheavychevy38

    dheavychevy38 Senior Member
    Messages: 283

    The truck has had the controller since the day it was bought in 03 and it has always worked up until now. I purchased the truck from the company that I work for so I know that it was in working order. As for the brake light that was working and just stoped within the last few days. I will defenitly check out that fuse on the side of the dash. Thanks guys and keep the ideas comeing.
     
  15. dheavychevy38

    dheavychevy38 Senior Member
    Messages: 283

    Well just ran out to check the fuse that MYCIRUS said to try and dead on that was it fixed both problems. Thanks for everyones help. :waving: Thats one less thing to fix. :laughing:
     
  16. mycirus

    mycirus Senior Member
    from Mass
    Messages: 589

    Sweet, glad I could help.
     
  17. mcwlandscaping

    mcwlandscaping 2000 Club Member
    Messages: 2,557

    Why did the fuse blow? Figuring that out may be a good idea...or at least giving all the wires and connections you can a real good look to check for any problems.
     
  18. dheavychevy38

    dheavychevy38 Senior Member
    Messages: 283

    Haven't figured that part ot yet but im guessing something to do with the trailer I had hooked to it the other day. Still have to some digging as to why but when I figure it out I will post up.
     
  19. mycirus

    mycirus Senior Member
    from Mass
    Messages: 589

    I just went out and troubleshot mine and the wires were in the wrong pins. Put the brake wire on the bottom left instead of top right and it works like a champ now. Its about time I did this, I was using manual brakes all this time.