1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

'02 Silverado, Fisher Plow. Truck headlamps won't shut off.

Discussion in 'Fisher Engineering Discussion' started by Corelli, Dec 9, 2009.

  1. Corelli

    Corelli Junior Member
    Messages: 10

    I have a 2002 Silverado 2500HD with a Fisher MM1 Solenoid Electric Plow.

    I can't get the headlights on the truck to shut off at all. Ignition switched off, key out and the lamps just keep on beaming. I also can't get the plow lights to come on when I connect the harness.

    I've even tried pulling any fuse/relay that says headlamp and DRL and the driver's side lamp stays lit, passenger side dims a lot but is still getting power.

    For now I've disconnected the battery but it's snowing like hell up here and I need to get some work done!
     
  2. wirenut

    wirenut Senior Member
    from nh
    Messages: 511

    pull the light harness from the black box ...relay prob fried or from the head lites themselves
     
  3. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,031

    I would say relay as well.
     
  4. Corelli

    Corelli Junior Member
    Messages: 10

    Thanks for the quick replies guys. I'm not sure which "black box" you're referring to though. Truck side? Are you guys talking about headlamp and DRL relays?
     
  5. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,031

    yup. Typically all tapped together in a hair ball...I mean box.
     
  6. Corelli

    Corelli Junior Member
    Messages: 10

    Got it. You guys were correct, bad relays on the plow's light harness. Just giving them a few taps got them "unstuck" but I'm going to clean up the connections and replace the relays for good measure.

    Repo thanks for your help (again, you helped me with something last year as well) How'd your day go yesterday? We got almost a foot here in Lewiston/Auburn but the rain beat it down hard. I sure hope the ground firms up soon... been pulling up grass all over the place. We're going to have a real mess this weekend. High's in the 20's.
     
  7. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,031

    No problem. we got just under 10" then packed down to 8" with the mix, even less then that in some areas. I know what your saying about the the grass. Absolutley horrible, it's not like we have a choice about it eitether, after the melting & freezing over the following days....those piles are staying were they landed for the season unless we get a good melt along the way.

    Check out my thread on my other experinces from yeasturday....

    http://www.plowsite.com/showthread.php?t=92735