1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

'02 Powerstroke questions

Discussion in 'Ford Trucks' started by Freddy130, Oct 19, 2009.

  1. Freddy130

    Freddy130 Senior Member
    Messages: 198

    Hopefully someone with more knowledge than me can answer two questions for me. This summer we got a 2002 F250 with the 7.3 psd/ zf 6 trans:

    Question one: When the truck is near but not at operating temperature the check engine light will come on with the truck's under load around 1700rpm and if you let of the gas pedal the light goes off or pick the rpms up more the light will go off. What am I dealing with?

    Question two: noticed lately that when the truck is sitting warming up with the park brake on the engine will occasonally go into a high idle mode 1100-1200 rpm as soon as the park brake is relased, brake or gas tapped it idles back down to normal. As far as I know the truck does not have a tuner or aux. idle control installed on it, is this a normal warm up feature on the truck?

    Hopefully some one can give me some guidance.

    Thanks,

    Freddy
     
  2. cretebaby

    cretebaby PlowSite Veteran
    Messages: 4,162

    Can't help you with #1 but #2 is completely normal.
     
  3. GPS

    GPS Senior Member
    from MA
    Messages: 268

    If the check engine light is coming on, the PCM should be storing a code. You'll need to have it scanned, as there are far too many possibilities to take shots in the dark.
     
  4. 02powerstroke

    02powerstroke PlowSite.com Addict
    Messages: 1,188

    sounds like a weak High pressure oil pump causeing the fuel pressure to drop under load.
     
  5. Freddy130

    Freddy130 Senior Member
    Messages: 198

    Sounds expensive lol, going in Wednesday to see if it is throwing a code.

    Thanks

    Freddy
     
  6. tom's snow pro

    tom's snow pro Member
    Messages: 55

    I have a 2001 ford f-350 powerstroke with the 7.3, and the idle deos the same thing when in park.
     
  7. MaineF250

    MaineF250 Senior Member
    from Maine
    Messages: 123

    #1 get it scanned and go to www.thedieselstop.com for everything you could want to know about that motor, the guys there are great
    #2 is perfectly normal, she's just trying to keep warm. All 20 of our internationals at work do the same thing
     
  8. Freddy130

    Freddy130 Senior Member
    Messages: 198

    Got the truck scanned Wednesday. The PCM is not storing a code. :confused: When the light comes on it doesn't have any noticable effect on the preformance. The light will only stay on for a second or two then go out again. Any ideas?

    Thanks
     
  9. veggin psd

    veggin psd Senior Member
    Messages: 276


    Get it scanned again. If there is a CEL there is a code. There are codes even if the CEL does not come on. They are called soft codes. There is a code there, just got to have a good enough scan tool to retrieve it.
     
  10. Case580M

    Case580M Senior Member
    Messages: 215

    I run the same truck . '02 7.3

    Some cheap scanners will not show a code if light is not on.

    Buy a good tuner then you will have a great scanner too.

    It could be a over or underboost condition. Sounds like a ACT giving you an issue.
     
  11. timberseal

    timberseal Senior Member
    from 46385
    Messages: 247

    $1300...... had to have mine changed last year unfortunately at 100,000 miles