1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

01 Chevy to 05 Chevy MVP Pro Plus problem

Discussion in 'Western Plows Discussion' started by UnderPSI, Feb 19, 2010.

  1. UnderPSI

    UnderPSI Junior Member
    Messages: 14

    I have an 05 Chevy 2500HD. I just got a MVP Pro Plus from an 01 Chevy 2500HD. It's an Ultra Mount set up and almost brand new. I have it installed and all wired up. The plow works great, the turn signals work fine, but the headlights don't work. Brights or driving lights. When I pull on the bright light stick the brights come on, but when I push the stick forward so the brights should stay on, they don't even light up.

    Not sure what to do from here. Thanks, I appreciate your time in helping me out with this.

    ~Brad.
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Headlight plug in harness's are different between '99-'02 and '03-newer. Just need the correct one for the '05.
     
  3. UnderPSI

    UnderPSI Junior Member
    Messages: 14

    Just the headlight harnesses? I figured itwould work because they have the same bulbs. Will the same isolater work?
     
  4. UnderPSI

    UnderPSI Junior Member
    Messages: 14

    Just the headlight harnesses? I figured itwould work because they have the same bulbs. Will the same isolater work?
     
  5. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    If you like to be really sure, go to the western site http://www.westernplows.com/ click on the "quick match". input the information (one vehicle at a time) of the vehicle, and compare the headlight harness numbers.
     
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Yes the bulbs are the same but the wiring isn't. '99-'02's are positive common and the '03-newer is negative common and is the reason they don't directly interchange. And all you need are the light harness's.

    Assuming you have a four port Isolation module (which yes you can reuse from the older truck) you'll need a 26351 and a 26352 light harness.
     
  7. UnderPSI

    UnderPSI Junior Member
    Messages: 14

    Thanks for the help! You guys are great.:D
     
  8. Mxrider069

    Mxrider069 Member
    Messages: 85

    i did this swap and had to switch the pins in the high beam harness and it worked fine for me...just switch the pins over in each plug and you should be good to go...
     
  9. SnowMatt13

    SnowMatt13 PlowSite.com Addict
    Messages: 1,535

    When I switched my uni-mount straight blade (01 to an 05) I had to go from a 9 pin to a 12 pin (different harness as B & B already said)
     
  10. UnderPSI

    UnderPSI Junior Member
    Messages: 14

    I'll give that a try right now. Did your low beams work or did you have to switch those too? Or does swapping the high beams fix the whole problem? Thanks again.


     
  11. UnderPSI

    UnderPSI Junior Member
    Messages: 14

    Where did you switch the pins? By the isolator, or the headlight bulbs in the truck or the plow light bulbs? Thanks.
     
  12. Mxrider069

    Mxrider069 Member
    Messages: 85

    i switced by the headlight bulbs in the truck
     
  13. UnderPSI

    UnderPSI Junior Member
    Messages: 14

    High and low beams or just high beams?
     
  14. Mxrider069

    Mxrider069 Member
    Messages: 85

    i beleive it was just the highs