Register free!
Search
 
     

Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 12-06-2009, 01:39 PM
loudredram loudredram is offline
Member
 
Join Date: Jan 2008
Location: Hopatcong NJ
Posts: 88
problems with salt dogg electric under tailgate salter

bought a new stainless under tailgate electric salter put about 1/2 ton through it and the auger stopped working last night. Controler turns on spinner comes on but auger wont start, the display flashes "F" in the auger spot then it flashes "A " in the auger and "A" in the spinner spot at the same time. Buyers dosent have any trouble shooting on any of there site and we didnt get anything from the dealer with it and there not open till monday morning and i need to get this going as were now down to 1 Vbox and our other truck is still has the leaf box in it .....HELP!
Reply With Quote
  #2  
Old 12-06-2009, 07:22 PM
Peterbilt's Avatar
Peterbilt Peterbilt is offline
Senior Member
 
Join Date: Apr 2007
Location: IA.
Posts: 747
Is it jammed? Maybe some sort of debris got in it and jammed up the auger. My Snow ex 2400s do that sometimes.

J.
__________________
Low-balling since 2005

SIMA Member
Reply With Quote
  #3  
Old 12-07-2009, 05:30 AM
loudredram loudredram is offline
Member
 
Join Date: Jan 2008
Location: Hopatcong NJ
Posts: 88
nothing jammed up opened it all up and cleaned it out
Reply With Quote
  #4  
Old 12-12-2009, 11:39 PM
gmcddtrucks gmcddtrucks is offline
Junior Member
 
Join Date: Nov 2008
Location: 4b
Posts: 8
Mine is doing the same thing tonight and I don't know how to fix it and need to salt NOW!!! Can't wait til monday morning!! Gonna be pissed if I have to push the salt by hand!!
Reply With Quote
  #5  
Old 12-12-2009, 11:43 PM
gmcddtrucks gmcddtrucks is offline
Junior Member
 
Join Date: Nov 2008
Location: 4b
Posts: 8
Just bought the stupid thing and had to replace the controller after the first time I tried to use it!! It worked fine for the second storm and now won't work!! RRRR!!
Reply With Quote
  #6  
Old 12-13-2009, 07:39 AM
loudredram loudredram is offline
Member
 
Join Date: Jan 2008
Location: Hopatcong NJ
Posts: 88
mine was a controller too. I didnt run salt on the last storm so who knows if this ne is going to make it threw a whole storm
Reply With Quote
  #7  
Old 12-13-2009, 12:31 PM
gmcddtrucks gmcddtrucks is offline
Junior Member
 
Join Date: Nov 2008
Location: 4b
Posts: 8
found out it has to do with the controller again, decided to hard wire the auger directly to a battery pack and it worked, got me through the night at least. Only thing is, is as soon as you hook up to the battery pack, you have to run into the truck and drive fast because the auger is on full speed and salt is pouring out. At least I didn't have to the parking lot by hand. Going to the dealer first thing in the morning.
Reply With Quote
  #8  
Old 12-13-2009, 01:26 PM
MKEPETE MKEPETE is offline
Junior Member
 
Join Date: Dec 2009
Location: MILWAUKEE
Posts: 3
Saltdogg salter problem

If you open the controller there are fuses inside. The code that is flashing sounds like a fuse has blow.
Reply With Quote
  #9  
Old 12-13-2009, 02:32 PM
cuttinscott cuttinscott is offline
Junior Member
 
Join Date: Dec 2009
Location: upstate NY
Posts: 15
Buyers stopped sourcing a USA made controller the Karrier controller was fine now they use a import digital box that does not like heavy loads like the 1400600SS v box with a bed chain .. We are waiting on a next gen Digital box tomorrow either that or I will call Karrier and get a OMEGA 2090 that will get the job done! BUYERS PLEASE LISTEN this controller box issue will kill your business!!



Scott
Reply With Quote
  #10  
Old 12-13-2009, 03:22 PM
basher's Avatar
basher basher is online now
2000 Club Member
 
Join Date: Nov 2004
Location: 19707
Posts: 8,617
Buyer never used a Karrier unit. They just shared a supplier.
__________________
Email at snowtech@basherandson.com
WEBSITE
Like us on Facebook!
Reply With Quote
  #11  
Old 12-13-2009, 08:13 PM
smoorman's Avatar
smoorman smoorman is offline
Sponsor
 
Join Date: Jan 2008
Location: Mentor, OH
Posts: 415
There are two very different things going on here.

1. As far as "overloading" the spreader - a 3/4HP electrical spreader is not a 10HP gas spreader. If you decide to make the change, you've got to keep that in mind. You can't set your baffles, etc. the same way. This has nothing to do with the controller. Hopefully your dealer can help you out with this. I'll try to come up with some guidelines and post them this week. I realize it's not fair just to say that its "different".

2. There IS a service alert out to dealers on a software issue on some of the new controllers. We identified an issue about a week ago, fixed it, and have been shipping replacement controllers to dealers where necessary. This might be responsible for LOUDEDRAM's issue. I will say that not having the controller codes in the instructions (or website) was a major oversight on our part. That will be corrected ASAP.

I realize that every minute you are down is money out of your pocket. We don't forget that. I realize that talk is cheap - but hopefully we back that up with our actions.
__________________
Scott Moorman
Director of Engineering
Buyers Products
Manufacturers of SnowDogg/ScoopDogg/SaltDogg Products
Reply With Quote
  #12  
Old 12-13-2009, 08:23 PM
gmcddtrucks gmcddtrucks is offline
Junior Member
 
Join Date: Nov 2008
Location: 4b
Posts: 8
Thank you. We searched all over the internet for the meanings of the codes/how to reset/fix the problem and could find nothing. We are going to the dealer tomorrow morning and hopefully will find something out there.
Reply With Quote
  #13  
Old 12-13-2009, 08:51 PM
loudredram loudredram is offline
Member
 
Join Date: Jan 2008
Location: Hopatcong NJ
Posts: 88
Scott...Thanks I am currently waiting for my new controller from my dealer, hopefully I will get the updated version. My dealer here in jersey is great they hooked me up with an older style controller till my new,one comes in. And yes some more tech. info in the manual would be great, so I can diagnose problem with out running to my dealer for every little thing.....BTW besides the controller issue the salter works great we are actually thinking of upgrading our other 2 vboxes to this style
Reply With Quote
  #14  
Old 12-14-2009, 08:53 AM
gmcddtrucks gmcddtrucks is offline
Junior Member
 
Join Date: Nov 2008
Location: 4b
Posts: 8
Called the dealer and found that the "F" flashing means that a fuse has blown and the "A" means that it came apart, because we disconnected it trying to figure out what happened. Gonna replace the fuse and see if that works.
Reply With Quote
  #15  
Old 12-15-2009, 09:15 PM
gmcddtrucks gmcddtrucks is offline
Junior Member
 
Join Date: Nov 2008
Location: 4b
Posts: 8
Replaced the fuse, everything is working good. Hope we have no more problems. Just a though for Salt Dogg - make the fuses externally accessible. Sure is a nice salter when it all comes together.
Reply With Quote
  #16  
Old 12-15-2009, 10:49 PM
PremierLand's Avatar
PremierLand PremierLand is offline
PlowSite.com Addict
 
Join Date: Jun 2004
Location: detroit
Posts: 1,572
I have the same problem. I just bought this last week, used it twice and now I have the F and the A : A code flashing....

Is it the fuse inside the controller or what. I need this fixed ASAP. I have a full load of salt in it right now and I need this to work.

Thanks!
Reply With Quote
  #17  
Old 12-16-2009, 05:10 AM
MKEPETE MKEPETE is offline
Junior Member
 
Join Date: Dec 2009
Location: MILWAUKEE
Posts: 3
saltdogg fuse

there are (5) 30 amp fuses inside the controller that plug into the circuit board.
Reply With Quote
  #18  
Old 12-16-2009, 07:50 PM
ARCTIC1000 ARCTIC1000 is offline
Junior Member
 
Join Date: Dec 2009
Location: michigan
Posts: 12
spreader

i have had the same problems with mine , from what i have noticed its a starting up issue , that it seems there is an over load or amp draw that tripes the box and it makes a clicking i have turned it off and on and it will start to work but not for long . i called dan @ buyers tech dept , he said i needed a new box part #3016212 that would fix it , so i picked one up on sat from my dealer installed it in the shop with the truck loaded with salt , sprayed salt all over and thought i was good , went to the job @ 2am ready to salt turned it on it worked for 5 min then same issue code " A" went back to shop pissed !!!
installed the orginal box went back out it worked great that nite , the next nite back out to salt hit the switch and code "A " again " wtf" so i called dan back tue am & left him a voice mail with my concerns . "and no return call" so i called today and got dan on the phone gave him the story and guess what we need another box . i called my dealer and said i need another box i will be in there in the am to get it ,my sales men also informed me that they are not seling this spreader any more due to the 20 units they have installed and all have problems ,companys are returning them daily , and the dealer is not getting any conncessions from buyers for the labor to uninstall the units.if the problem is not corrected with this new box , i wil be also returning this spreader . im thinking i should have spent the $ 1,000.00 more for the snow-x 2400

tx john 586-630-6552
Reply With Quote
  #19  
Old 12-16-2009, 09:37 PM
3bladz 3bladz is offline
Senior Member
 
Join Date: Dec 2005
Location: Central IL
Posts: 139
Boy this is not an encouraging thread. I just bought one of these units and this is not instilling much faith in my purchase. I have not even ran it yet, but sure dont want to find out it doesn't work at 1AM.
I am very disappointed in the manual. It virtually has no operating instructions.
If there is a new controller, I want it now. Not after I am loaded with salt and this thing doesn't work.
__________________
>>>>Boss leads the way<<<<
11 F250 x2 (6.7 & 6.2) Boss 9'DXT
02 F450 7.3 dump w/Buyers Saltdogg SS 12v UTG
99 F250 Boss 9'2 poly Flat top
2004 Wrangler Rubicon w/ Boss 8'VXT
John Deere 5105M w 10' Artic pusher
John Deere 3720 & 74" snowblower
Toolcat 5610 & 8 foot pusher (SOLD)

The picture is our Ford 8N with Bombardier halftracks and a Dearborn V plow
Reply With Quote
  #20  
Old 12-16-2009, 10:20 PM
3bladz 3bladz is offline
Senior Member
 
Join Date: Dec 2005
Location: Central IL
Posts: 139
Quote:
Originally Posted by smoorman View Post
There are two very different things going on here.

1. As far as "overloading" the spreader - a 3/4HP electrical spreader is not a 10HP gas spreader. If you decide to make the change, you've got to keep that in mind. You can't set your baffles, etc. the same way. This has nothing to do with the controller. Hopefully your dealer can help you out with this. I'll try to come up with some guidelines and post them this week. I realize it's not fair just to say that its "different".
Where will I find this info? I am going from a tailgate spreader. How should I know where to set baffles??? I am not expecting the performance of a full hydraulic spreader travelling 40mph down the road spreading, but I am expecting reliability. If I need to make adjustments beyond auger and spinner speed, I am gonna need to know that before I have it full of salt in the middle of the night

2. There IS a service alert out to dealers on a software issue on some of the new controllers. We identified an issue about a week ago, fixed it, and have been shipping replacement controllers to dealers where necessary. This might be responsible for LOUDEDRAM's issue. I will say that not having the controller codes in the instructions (or website) was a major oversight on our part. That will be corrected ASAP.

I realize that every minute you are down is money out of your pocket. We don't forget that. I realize that talk is cheap - but hopefully we back that up with our actions.
Thanks in advance for your "action"
__________________
>>>>Boss leads the way<<<<
11 F250 x2 (6.7 & 6.2) Boss 9'DXT
02 F450 7.3 dump w/Buyers Saltdogg SS 12v UTG
99 F250 Boss 9'2 poly Flat top
2004 Wrangler Rubicon w/ Boss 8'VXT
John Deere 5105M w 10' Artic pusher
John Deere 3720 & 74" snowblower
Toolcat 5610 & 8 foot pusher (SOLD)

The picture is our Ford 8N with Bombardier halftracks and a Dearborn V plow
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©2000 - 2012 PlowSite.comô Moose River Media
All times are GMT -5. The time now is 08:00 AM.

Page generated in 0.03408 seconds with 8 queries