Register free!
Search
 
     

Click for Weather
  #1  
Old 02-06-2011, 09:44 AM
szxjw3 szxjw3 is offline
Junior Member
 
Join Date: Nov 2004
Location: richmond mi
Posts: 25
fisher plow angle and lift problem

I have a fisher plow that wont angle or lift. the motor does run. the blade move a little. also I am getting a buzzing noise from the isolation module and the in cab plow control buzzes when I move it into the down float position. Any help would be appreciated.
Reply With Quote
  #2  
Old 02-06-2011, 05:35 PM
chevyzrule810's Avatar
chevyzrule810 chevyzrule810 is offline
Senior Member
 
Join Date: Oct 2010
Location: Northeast
Posts: 858
What kind of truck do you have? That is the first question.Is the motor running continuously? If the plow won't lift or angle you could have a clogged filter or a worn or damaged pump.Have you checked the connections at the battery cables? Your 1 and 2 solenoids may not be shifting or your Poppet check valve not opening
__________________
2006 Silverado 2500HD
8" Fisher HD Minute Mount 2
Reply With Quote
  #3  
Old 02-06-2011, 06:17 PM
szxjw3 szxjw3 is offline
Junior Member
 
Join Date: Nov 2004
Location: richmond mi
Posts: 25
battery cables are checked. filter was checked.motor only runs when I move the switch. the truck is a 2006 chevy.Pump is only a year old. stopped working with no other symtoms. Still have buzzing noise in the switch and in the isolation module. ant other ideas?

Last edited by szxjw3; 02-06-2011 at 06:21 PM.
Reply With Quote
  #4  
Old 02-06-2011, 07:53 PM
chevyzrule810's Avatar
chevyzrule810 chevyzrule810 is offline
Senior Member
 
Join Date: Oct 2010
Location: Northeast
Posts: 858
can you try the plow with another truck?
__________________
2006 Silverado 2500HD
8" Fisher HD Minute Mount 2
Reply With Quote
  #5  
Old 02-06-2011, 10:41 PM
brad96z28's Avatar
brad96z28 brad96z28 is offline
PlowSite.com Addict
 
Join Date: Aug 2005
Location: easton/taunton mass
Posts: 1,515
Had the same problem once. Switching the power wire going to the controller fixed it. It was hooked up in the box where the trailer brake wirng goes It did not like it there. Did the same exact thing on a 2004 chevy.
__________________
04.5 gmc 2500hd da/cc
8.6 xv
whelen edge
ktm 450 exc
mxz rev 800
husqvarna 1130
Reply With Quote
  #6  
Old 02-07-2011, 10:15 AM
szxjw3 szxjw3 is offline
Junior Member
 
Join Date: Nov 2004
Location: richmond mi
Posts: 25
I will move the power to a different position. The good news is this morning after keeping it in the barn over night it started to work. I think it might have frozen up. I plan to flush and fill the system today. I broke the rule and did not change it from last year.
Reply With Quote
  #7  
Old 02-07-2011, 10:52 AM
chevyzrule810's Avatar
chevyzrule810 chevyzrule810 is offline
Senior Member
 
Join Date: Oct 2010
Location: Northeast
Posts: 858
Maybe you have some water in the fluid as well.When you change it make sure you use the fluid in the blue container from fisher and change the pickup filter while your at it.
__________________
2006 Silverado 2500HD
8" Fisher HD Minute Mount 2
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©2000 - 2012 PlowSite.comô Moose River Media
All times are GMT -5. The time now is 02:34 AM.

Page generated in 0.02327 seconds with 7 queries