Register free!
Search
 
     

Click for Weather
  #1  
Old 08-29-2010, 02:36 PM
performanceplus performanceplus is offline
Member
 
Join Date: Dec 2009
Location: Central CT
Posts: 93
Plow wont go right/left

I went to move my plow yesterday and when I picked it up I had no side to side movement. I tried to go left and it started to raise up real slow. I went to go right and it sounded like the cylinder was trying but couldn't move. I imagine it needs new cylinders but not sure. Any ideas/help? Thanks.
Reply With Quote
  #2  
Old 08-29-2010, 05:02 PM
quigleysiding quigleysiding is offline
Senior Member
 
Join Date: Oct 2009
Location: North Kingstown,Rhode Island
Posts: 950
Try kicking it with someone holding the control left or right. Last year mine did that all it needed was a little help to get loose again. It was fine all year.
__________________
Dodge 1997 3500
Meyer sander gas
Fisher 9 ft

Dodge 1997 2500
Airflo sander electric
Fisher 8 ft

Dodge 1997 2500
Fisher 8 ft
Reply With Quote
  #3  
Old 08-29-2010, 05:05 PM
performanceplus performanceplus is offline
Member
 
Join Date: Dec 2009
Location: Central CT
Posts: 93
Do you have a MM2? I will give that a try.
Reply With Quote
  #4  
Old 08-29-2010, 05:11 PM
quigleysiding quigleysiding is offline
Senior Member
 
Join Date: Oct 2009
Location: North Kingstown,Rhode Island
Posts: 950
My plow is a mm1. You said you could here the motor running so it might be just stuck.
__________________
Dodge 1997 3500
Meyer sander gas
Fisher 9 ft

Dodge 1997 2500
Airflo sander electric
Fisher 8 ft

Dodge 1997 2500
Fisher 8 ft
Reply With Quote
  #5  
Old 09-08-2010, 06:27 PM
gtmustang00 gtmustang00 is online now
Senior Member
 
Join Date: Feb 2010
Location: southern nh
Posts: 617
My buddies plow was doing the same thing. It wasn't the stick it was one of the plugs had a few loose wires going into it on the plow side. Have a buddy wiggle the wiring while you have the stick angled.
Reply With Quote
  #6  
Old 09-17-2010, 11:36 AM
NHresident NHresident is offline
Senior Member
 
Join Date: Jun 2008
Location: north east
Posts: 144
try chkng the fluid
Reply With Quote
  #7  
Old 09-17-2010, 01:41 PM
bullettooth81 bullettooth81 is offline
Senior Member
 
Join Date: Sep 2009
Location: NE South Dakota
Posts: 103
I had the same thing happen to my Boss the first time I used it last year. It was just stuck from sitting over the summer. I got out and kicked it a few times, then pushed ito a pile and it started working. Worked perfect for the rest of the year.
__________________
Reply With Quote
  #8  
Old 09-26-2010, 10:23 AM
TeamBrain Damag TeamBrain Damag is offline
Junior Member
 
Join Date: Sep 2009
Location: MA/NH
Posts: 6
check the wiring, I have used MM1 did the same thing, the previous owner changed the end plug, and one of the wires came loose.
Reply With Quote
  #9  
Old 09-26-2010, 11:46 AM
Grassman09 Grassman09 is offline
2000 Club Member
 
Join Date: Mar 2009
Location: Mississauga, Ontario
Posts: 2,674
Check to make sure all the pins are in tact and not corroded. I always had the same issues the blade would do the opposite of what you pushed on the controller. I had to get out and wiggle the plug as they didn't make proper contact.
__________________
Truck, Plows,Tractor, Mowers Shovels & Salters.
Our YouTube videos.
Like us on Facebook
www.treelawny.com
Reply With Quote
  #10  
Old 09-28-2010, 07:02 PM
buddymanzpop buddymanzpop is offline
Senior Member
 
Join Date: Nov 2009
Location: central mass
Posts: 558
S2 cartridge could be stuck or not energized, check for magnetism at the coil when action is requested from the controller, if magnetism is present you will have to pull the cartridge and check that for movement, you'll need a helper to do this seeing how it's pretty impossible to activate the controller and check for function at the valve pump assembly at the same time.
Reply With Quote
  #11  
Old 10-02-2010, 07:49 AM
SnoPro Inc's Avatar
SnoPro Inc SnoPro Inc is offline
Senior Member
 
Join Date: Sep 2010
Location: South West Michigan
Posts: 113
Check hydro oil, maybe a bad solenoid?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©2000 - 2012 PlowSite.comô Moose River Media
All times are GMT -5. The time now is 01:19 PM.

Page generated in 0.03029 seconds with 7 queries