Register free!
Search
 
     

Click for Weather
  #1  
Old 01-02-2010, 01:56 PM
pholverson pholverson is offline
Junior Member
 
Join Date: Jan 2007
Location: Illinois
Posts: 3
pump keeps running for short time

My pump keeps running after the plow is raised. usually just a short time, but today when I was preparing to change fluid it kept running even after I shut off the ignition. I'm thinking this is a sticking motor relay. Does that sound right? Any suggestions for best place to buy online?
Thanks,
Reply With Quote
  #2  
Old 01-02-2010, 06:16 PM
no lead's Avatar
no lead no lead is offline
PlowSite.com Addict
 
Join Date: Dec 2008
Location: battle creek MI
Posts: 1,308
a loose connection usually make a solenoid stick. i have a stack if them.
__________________
riverview excavating and snowplowing.
battle creeks full service western dealer.

check us out on facebook http://www.facebook.com/profile.php?...00001553776640

feel free to p.m.
Reply With Quote
  #3  
Old 01-03-2010, 09:34 AM
twinman326's Avatar
twinman326 twinman326 is offline
PlowSite.com Addict
 
Join Date: Dec 2007
Location: New York
Posts: 1,683
Just could have a bad solenoid, or a ground problem..
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©2000 - 2012 PlowSite.comô Moose River Media
All times are GMT -5. The time now is 01:17 PM.

Page generated in 0.01793 seconds with 9 queries