Register free!
Search
 
     

Click for Weather
  #1  
Old 11-08-2012, 03:48 AM
7d9_z28's Avatar
7d9_z28 7d9_z28 is offline
Senior Member
 
Join Date: Dec 2010
Location: ferrysburg,MI
Posts: 235
EZ-V not cooperating

I havent started digging into the schematics yet, wanted to start by asking you guys:

Bought a used 8'6" EZ-V, was told it worked fine (of course it did ) Hooked it up for the first time today and this is what I got: Lift cylinder went all the way up and stuck. Float enabled, cylinder would not budge. Both wings went back one at a time into Vee mode.. and stayed. no wing mode, no scoop, no straight.

I checked all the connections, I heard the solenoid clicking. I have to be missing something!

Any Ideas?
__________________
2001 Silverado 2500HD LT 8.1/Allison CCSB Fisher EZ-V 8.6
79 Camaro Z28 - lifetime project
Reply With Quote
  #2  
Old 11-08-2012, 07:56 AM
Morrissey snow removal's Avatar
Morrissey snow removal Morrissey snow removal is offline
PlowSite.com Addict
 
Join Date: Sep 2006
Location: lunenburg, ma
Posts: 1,800
check the cartidges and soilenods on the vavle body
__________________
Ford Trucks
Fisher Plows
ice o way Sanders
Caterpillar Equipment
Reply With Quote
  #3  
Old 11-08-2012, 08:06 AM
mksent02 mksent02 is offline
Member
 
Join Date: Feb 2012
Location: N Syracuse NY
Posts: 32
Sounds like maybe the s3 valve is stuck? It's the back side center valve.
did you see the plow work correctly at all?
Reply With Quote
  #4  
Old 11-08-2012, 10:04 AM
unhcp unhcp is online now
PlowSite.com Addict
 
Join Date: Jan 2010
Location: seacoast nh
Posts: 1,056
does the controller have the red power light?
__________________
www.whitemountainplowing.com
Reply With Quote
  #5  
Old 11-08-2012, 04:34 PM
7d9_z28's Avatar
7d9_z28 7d9_z28 is offline
Senior Member
 
Join Date: Dec 2010
Location: ferrysburg,MI
Posts: 235
Controller has red power light, green float light when enabled, and full back-lighting.

I did NOT see it working (I know, I'm an idiot)

I will pull apart the valve body, starting with S3, when I get back out there

Thank you, any other suggestions are welcome (except "Don't buy used equipment without seeing it work first")
__________________
2001 Silverado 2500HD LT 8.1/Allison CCSB Fisher EZ-V 8.6
79 Camaro Z28 - lifetime project
Reply With Quote
  #6  
Old 11-08-2012, 04:59 PM
unhcp unhcp is online now
PlowSite.com Addict
 
Join Date: Jan 2010
Location: seacoast nh
Posts: 1,056
check all our wiring, make sure the pump has fluid
__________________
www.whitemountainplowing.com
Reply With Quote
  #7  
Old 11-08-2012, 06:15 PM
mksent02 mksent02 is offline
Member
 
Join Date: Feb 2012
Location: N Syracuse NY
Posts: 32
I buy stuff like that ALL the time. Bought one literally in pieces once and with only a few pics. Just making sure it didn't just start happening - you know like "it worked before I stuffed it in the back of my Yugo"... Anyway the mechanics guide is real helpful and the S3 solenoid is on for up and down & V and scoop, that's why I suggested that. Hopefully you find a bad coil or dirty valve. Good luck!
Reply With Quote
  #8  
Old 11-08-2012, 07:52 PM
7d9_z28's Avatar
7d9_z28 7d9_z28 is offline
Senior Member
 
Join Date: Dec 2010
Location: ferrysburg,MI
Posts: 235
Yeah I got the user manual, mechanics guide, and exploded diagrams in a big binder. I have to dig through them. IM SO LAZY!!!

Thanks again!
__________________
2001 Silverado 2500HD LT 8.1/Allison CCSB Fisher EZ-V 8.6
79 Camaro Z28 - lifetime project
Reply With Quote
  #9  
Old 11-09-2012, 11:36 AM
Morrissey snow removal's Avatar
Morrissey snow removal Morrissey snow removal is offline
PlowSite.com Addict
 
Join Date: Sep 2006
Location: lunenburg, ma
Posts: 1,800
sometimes they can be a pain good luck with it
__________________
Ford Trucks
Fisher Plows
ice o way Sanders
Caterpillar Equipment
Reply With Quote
  #10  
Old 11-09-2012, 04:53 PM
7d9_z28's Avatar
7d9_z28 7d9_z28 is offline
Senior Member
 
Join Date: Dec 2010
Location: ferrysburg,MI
Posts: 235
Thank you! Im headed out there in about 30 minutes... Hopefully its something simple (though it never is)
__________________
2001 Silverado 2500HD LT 8.1/Allison CCSB Fisher EZ-V 8.6
79 Camaro Z28 - lifetime project
Reply With Quote
  #11  
Old 11-09-2012, 10:35 PM
07PSDCREW's Avatar
07PSDCREW 07PSDCREW is offline
Senior Member
 
Join Date: Sep 2011
Location: Berlin, Ma
Posts: 787
How'd ya make out with the issue??
Reply With Quote
  #12  
Old 11-10-2012, 12:52 AM
7d9_z28's Avatar
7d9_z28 7d9_z28 is offline
Senior Member
 
Join Date: Dec 2010
Location: ferrysburg,MI
Posts: 235
Uhm. My procrastination kicked in (or, more likely, never kicked out).

Tomorrow (later today) as soon as it gets light enough
__________________
2001 Silverado 2500HD LT 8.1/Allison CCSB Fisher EZ-V 8.6
79 Camaro Z28 - lifetime project
Reply With Quote
  #13  
Old 11-10-2012, 07:03 AM
plowman_25 plowman_25 is offline
Member
 
Join Date: Nov 2005
Location: Gorham Maine
Posts: 71
I would also check the controller harness on the truck side. I had the same issues last year, turns out the wires had started to go bad internally where they go into the plug end that connects to the plow side harness. It would stick just like you said, but as soon as I wiggled the plug a little it work fine again. You can get a replacement plug end if that is the issue
__________________
2008 F350 CCSB 6.4L Diesel
Fisher mm2 8.6 XV
Reply With Quote
  #14  
Old 11-10-2012, 10:48 AM
7d9_z28's Avatar
7d9_z28 7d9_z28 is offline
Senior Member
 
Join Date: Dec 2010
Location: ferrysburg,MI
Posts: 235
I did wiggle the plugs a bit with no change, but thats not to say it cant be the problem. I did notice that it might actually be missing a pin...

Thank you for reminding me!
__________________
2001 Silverado 2500HD LT 8.1/Allison CCSB Fisher EZ-V 8.6
79 Camaro Z28 - lifetime project
Reply With Quote
  #15  
Old 11-10-2012, 01:51 PM
7d9_z28's Avatar
7d9_z28 7d9_z28 is offline
Senior Member
 
Join Date: Dec 2010
Location: ferrysburg,MI
Posts: 235
UPDATE: I pulled all three coils off the valves.. ALL OF THEM were filled with corrosion. After a good cleaning and some QD Electrical cleaner, I pulled S3, everything seemed to check out. Reassembled, topped of the fluid, Sprayed out the truck-to-plow connectors (they had di-ele. grease that was gummed up and brown in them) and hooked up to my truck. It is on a trailer right now, so I didn't go nuts, but it DOES function. The drop seems really stiff... I put it in float mode, and had to stand on top of the lift plate... Not sure if thats normal (I know the V plow is heavy, I'm sure its different when actually suspended in mid air)

Thank you for the help and suggestions! I really appreciate it!
__________________
2001 Silverado 2500HD LT 8.1/Allison CCSB Fisher EZ-V 8.6
79 Camaro Z28 - lifetime project
Reply With Quote
  #16  
Old 11-10-2012, 03:32 PM
mksent02 mksent02 is offline
Member
 
Join Date: Feb 2012
Location: N Syracuse NY
Posts: 32
Good to know it's fixed. You might want to change the fluid.
Reply With Quote
  #17  
Old 11-10-2012, 03:59 PM
7d9_z28's Avatar
7d9_z28 7d9_z28 is offline
Senior Member
 
Join Date: Dec 2010
Location: ferrysburg,MI
Posts: 235
After leveling the trailer out I checked it again (yeah, I know) And it was low again (duh) so I re-topped it off.

As soon as the push plates show up (Found a set for $50!) I will hook it all up and see what it does!

__________________
2001 Silverado 2500HD LT 8.1/Allison CCSB Fisher EZ-V 8.6
79 Camaro Z28 - lifetime project
Reply With Quote
  #18  
Old 11-10-2012, 04:04 PM
Morrissey snow removal's Avatar
Morrissey snow removal Morrissey snow removal is offline
PlowSite.com Addict
 
Join Date: Sep 2006
Location: lunenburg, ma
Posts: 1,800
good luck with it this yr
__________________
Ford Trucks
Fisher Plows
ice o way Sanders
Caterpillar Equipment
Reply With Quote
  #19  
Old 11-10-2012, 04:07 PM
7d9_z28's Avatar
7d9_z28 7d9_z28 is offline
Senior Member
 
Join Date: Dec 2010
Location: ferrysburg,MI
Posts: 235
Thanks! My first time with a V plow, My first time with a plow over 7'6", And my first time plowing with the truck I have always wanted to plow with!

There are a couple Hydraulic lines that the outer rubber is wore off of. Over the next couple pay checks I will set aside for new lines, and probably drain and refill the system then.

Thanks Again Guys!
__________________
2001 Silverado 2500HD LT 8.1/Allison CCSB Fisher EZ-V 8.6
79 Camaro Z28 - lifetime project
Reply With Quote
  #20  
Old 11-15-2012, 03:39 AM
7d9_z28's Avatar
7d9_z28 7d9_z28 is offline
Senior Member
 
Join Date: Dec 2010
Location: ferrysburg,MI
Posts: 235
UPDATE: DID IT AGAIN!!!! Same thing, nothing worked, then the left turn button made it raise up. Wiggled the controller connector and it started working fine. The twist-lock is cracked and is not holding the connector in place!

On the bright side, the proper push plates are on the truck (only paid $50 for the pair, and they are in great shape!) and the plow was on and fully functioning. I do have some slight leaks to tend to, and since we used a HI-LO to put it on, I didn't know until I got home that the chain is too short so when I dropped it I couldn't unhook it from the truck!
__________________
2001 Silverado 2500HD LT 8.1/Allison CCSB Fisher EZ-V 8.6
79 Camaro Z28 - lifetime project
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©2000 - 2012 PlowSite.comô Moose River Media
All times are GMT -5. The time now is 09:53 AM.

Page generated in 0.03224 seconds with 9 queries