PDA

View Full Version : new western plow will not lower. HELP


kubotazd21
12-07-2005, 10:31 PM
Bought my new Western 7 1/2 plow last January, brought it home and parked it in the barn, and it has set there ever since, until today. It is still brand new, and never has been used. My problem is that after I hooked it up and raised it to back it out of the barn, it will now not lower. It will turn left and right, no problem at all, and when you try to raise it you can hear the motor trying to lift, but when you try to lower it with the handheld controller it does nothing at all. I have checked and cannot find any blown fuses. The unit is still under warranty, but the dealer that I purchased it from is 2 hours away. Does anyone have any suggestions at all what the problem might be....Thanks...

Midwest
12-07-2005, 10:55 PM
I looked in my Fisher Troubleshooting guide, It may not be much help but this is what it says;

Hydraulic fluid not correct for outside temperature
Blown fuse in Fisher vehicle control harness
Control or hydraulic system malfunction or fault in wiring

I know its not a western, but it might be helpful

See if Western has a downloadable mechanics guide on their website, I know fisher does, but It takes 3 hours to download on my 57k

deh8255
12-08-2005, 01:23 AM
I would check to see if power is getting to the lowering solenoid. That is where I would go next. That is the most likely suspect. Less likely is the spool itself being stuck.

kubotazd21
12-08-2005, 05:16 AM
i have checked the lowering solenoid with a tester no power at all. What would cause this? Also could it be the handheld controller? I really do not think so, because it is also brand new and never been used either. Thanks

infineon954
12-08-2005, 06:48 AM
Take the timeout (if you have time that is) and take it back to the dealer. If you were to mess something up they might be asses and say that we did not work on it, so we can't honor the warranty. Plus, you should not have these problems on a brand new Western. That's my opinion anyway.

Luppy
12-08-2005, 07:01 AM
I'd take it back to the dealer too but first I'd unplug all the wires and plug them back in. On my plow there's red, green, and black wires that plug in and if they aren't plugged in tight or the connections are dirty that's all it takes for no worky. When I first hooked mine up this year it wouldn't go down but I had air in the lines. My plow is a meyer but I'm sure your western got wiring too so it can't hurt to check your wires before calling the dealer. Doing that won't void your warranty and may save you from feeling like a jackass if it is just a plug which is highly likely on a brand new setup that worked fine when you had it on last. G'luck!:waving: