PDA

View Full Version : Maintenance question on SEHP


KenG
10-17-2005, 08:45 PM
I just re-assembled my Fisher MM1 setup for my truck (fresh paint, pins, hoses, etc.)

I went to refill the fluid, and ran into a little problem. My SEHP has the filler plug behind the motor, but no fluid level plug in the side of the housing (contrary to what my owner's manual shows).
I went to Fisher's website and read the PDF version of the owner's guide, and it says the same as my hard copy. Do I have an odd version of the SEHP? How do I correctly set the fluid level without the "level plug"?

Any help would be greatly appreciated.

Crash935
10-18-2005, 05:51 PM
Thats odd, no vent! Does your power unit still have the fisrher serial number sticker on the front? I'm thinking it might be an aftermarket case?

Easiest way to fill that is to just pop the motor off and dump 1.75 quarts into it (or unitll it just about runs over the front edge of the case). Otherwise the only other thing to do is pour some fluid into the fill hole and wait for it to burp or settle and then add some more, you have to keep doing this untill its full but the burp and settle thing usually doesnt start until you have the first quart in.

KenG
10-18-2005, 06:27 PM
Thanks, Crash.

My hydraulic pack does still have the Fisher tag on the main housing.

I think I found what I am looking for. I went on Western's website. Looked through their tech publications and found it with conventional plow setups (even though I have a Fisher Minute Mount)with solenoid operating systems.

I went back to Fisher's site and found it with conventional mount SEHP systems.
http://www.fishersnowplows.com/pdf/6395_000392.pd

rbergevine
11-05-2008, 07:55 PM
Glad to find this post - I just posted a new thread asking about this exact issue on my housing.